CentOSPlesk

CentOS: Plesk Not Responding

Para Arreglar esto tuve que cambiar chmod 777 /etc/my.cnf

 

Plesk Control Panel shows error after upgrade to version 10.0.1

Article ID: 9266

Last Review: Apr, 16 2012

Views:

APPLIES TO:

  • Parallels Plesk Panel 10.x for Linux

Fixed since

The problem described in this KB article is completely fixed in Parallels Plesk Panel version 10.4.x and later versions.

Symptoms

After upgrading Parallels Plesk Panel to version 10.0.1, the following error message is shown on the login page:

ERROR: Zend_Log_Exception
“/usr/local/psa/admin/logs/panel.log” cannot be opened with mode “a”

0: Stream.php:66
Zend_Log_Writer_Stream->__construct(string ‘/usr/local/psa/admin/logs/panel.log’)
1: Abstract.php:84
CommonPanel_Application_Abstract->_initLog()
2: Abstract.php:31
CommonPanel_Application_Abstract->run()
3: Abstract.php:19
CommonPanel_Application_Abstract::init()
4: auth.php3:137

However, all packages and databases have been upgraded:

# rpm -q psa
psa-10.0.1-cos5.build109101029.18

# mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e”select * from misc where param=’version'”
+———+——-+
| param   | val   |
+———+——-+
| version | 01090 |
+———+——-+
#
And the file /usr/local/psa/version is empty:

# cat /usr/local/psa/version
#

Resolution

The post-upgrade script was not executed correctly. To fix the error, perform post-upgrade configuration repair by executing the bootstrapper script.
Bootstrapper script can be found in the directory $PRODUCT_ROOT_DIbootstrapper/.

# /usr/local/psa/bootstrapper/pp10.9.0-bootstrapper/bootstrapper.sh repair
……….
**** Product repair completed successfully.
After repairing the configuration, you should be able to access the Control Panel.

 

Leave a Reply

Your email address will not be published. Required fields are marked *